Головна Головна -> Реферати українською -> Інформатика, комп'ютери, програмування -> Знаходження коренів рівняння методом поділу відрізка пополам

Знаходження коренів рівняння методом поділу відрізка пополам

Назва:
Знаходження коренів рівняння методом поділу відрізка пополам
Тип:
Реферат
Мова:
Українська
Розмiр:
19,97 KB
Завантажень:
78
Оцінка:
 
поточна оцінка 5.0


Скачати цю роботу безкоштовно
Гарною вправою по роботі з MS Excel є програмування на робочому листі алгоритму пошуку кореня рівняння F(x) = 0 методом поділу відрізка навпіл. Нехай неперервна функція F(x) має значення різних знаків на кінцях відрізка [а; Ь], тобто

F(a)F(b) < 0.

Тоді рівняння F(x) = 0 має корінь всередині цього відрізка. Відрізок [а; Ь] називається відрізком локалізації кореня.

Нехай с = (а + Ь) / 2 - середина відрізка [а; Ь].

Якщо F(a)F(c) < 0 , то корінь знаходиться на відрізку [а; сз], який беремо за новий відрізок локалізації кореня. Якщо F(a)F(c) > 0 , то за новий відрізок локалізації кореня беремо [сз; Ь]. Відзначимо, що новий відрізок локалізації кореня в два рази менший первісного. Процес розподілу відрізка для локалізації кореня продовжуємо доти, поки його довжина не стане менше ?, точності знаходження кореня. У цьому випадку будь-яка точка відрізка локалізації відрізняється від кореня не більше ніж на ? /2.

На рис. 3.20 приведені результати знаходження кореня з точністю до 0,001 методом поділу відрізка навпіл рівняння х2 - 2 = 0 . За первісний відрізок локалізації кореня обраний інтервал [0; 2].

Для реалізації цього методу введіть в чарунки робочого листа формули або значення (табл. 3.2).

Таблиця 3.2 - Формули для знаходження коренів рівняння

Чарунка Формула чи значення

В1 0.001

A3 0

B3 2

C3 =(A3+B3)/2

D3 =(A3^2-2)*(C3^2-2)

E3 =C3^2-2

F3 =ЕСЛИ(В3-А3

Завантажити цю роботу безкоштовно



Реферат на тему: Знаходження коренів рівняння методом поділу відрізка пополам

BR.com.ua © 1999-2017 | Реклама на сайті | Умови використання | Зворотній зв'язок